Providers packages reference

Here’s the list of the provider packages and what they enable:

apache-airflow-providers-airbyte

Airbyte

To install, run:

pip install 'apache-airflow-providers-airbyte'
Available versions

3.1.0, 3.0.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.airbyte

apache-airflow-providers-alibaba

Alibaba Cloud integration (including Alibaba Cloud).

To install, run:

pip install 'apache-airflow-providers-alibaba'
Available versions

2.0.1, 2.0.0, 1.1.1, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.alibaba

apache-airflow-providers-amazon

Amazon integration (including Amazon Web Services (AWS)).

To install, run:

pip install 'apache-airflow-providers-amazon'
Available versions

5.0.0, 4.1.0, 4.0.0, 3.4.0, 3.3.0, 3.2.0, 3.1.1, 3.0.0, 2.6.0, 2.5.0, 2.4.0, 2.3.0, 2.2.0, 2.1.0, 2.0.0, 1.4.0, 1.3.0, 1.2.0, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.amazon

apache-airflow-providers-apache-beam

Apache Beam.

To install, run:

pip install 'apache-airflow-providers-apache-beam'
Available versions

4.0.0, 3.4.0, 3.3.0, 3.2.1, 3.2.0, 3.1.0, 3.0.1, 3.0.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.beam

apache-airflow-providers-apache-cassandra

Apache Cassandra.

To install, run:

pip install 'apache-airflow-providers-apache-cassandra'
Available versions

3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.cassandra

apache-airflow-providers-apache-drill

Apache Drill.

To install, run:

pip install 'apache-airflow-providers-apache-drill'
Available versions

2.2.0, 2.1.0, 2.0.0, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.drill

apache-airflow-providers-apache-druid

Apache Druid.

To install, run:

pip install 'apache-airflow-providers-apache-druid'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.druid

apache-airflow-providers-apache-hdfs

Hadoop Distributed File System (HDFS) and WebHDFS.

To install, run:

pip install 'apache-airflow-providers-apache-hdfs'
Available versions

3.1.0, 3.0.1, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.hdfs

apache-airflow-providers-apache-hive

Apache Hive

To install, run:

pip install 'apache-airflow-providers-apache-hive'
Available versions

4.0.0, 3.1.0, 3.0.0, 2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.3, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.hive

apache-airflow-providers-apache-kylin

Apache Kylin

To install, run:

pip install 'apache-airflow-providers-apache-kylin'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.kylin

apache-airflow-providers-apache-livy

Apache Livy

To install, run:

pip install 'apache-airflow-providers-apache-livy'
Available versions

3.1.0, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.livy

apache-airflow-providers-apache-pig

Apache Pig

To install, run:

pip install 'apache-airflow-providers-apache-pig'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.pig

apache-airflow-providers-apache-pinot

Apache Pinot

To install, run:

pip install 'apache-airflow-providers-apache-pinot'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.pinot

apache-airflow-providers-apache-spark

Apache Spark

To install, run:

pip install 'apache-airflow-providers-apache-spark'
Available versions

3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.3, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.spark

apache-airflow-providers-apache-sqoop

Apache Sqoop

To install, run:

pip install 'apache-airflow-providers-apache-sqoop'
Available versions

3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.apache.sqoop

apache-airflow-providers-arangodb

ArangoDB

To install, run:

pip install 'apache-airflow-providers-arangodb'
Available versions

2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.arangodb

apache-airflow-providers-asana

Asana

To install, run:

pip install 'apache-airflow-providers-asana'
Available versions

2.0.1, 2.0.0, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.asana

apache-airflow-providers-celery

Celery

To install, run:

pip install 'apache-airflow-providers-celery'
Available versions

3.0.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.celery

apache-airflow-providers-cloudant

IBM Cloudant

To install, run:

pip install 'apache-airflow-providers-cloudant'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.cloudant

apache-airflow-providers-cncf-kubernetes

Kubernetes

To install, run:

pip install 'apache-airflow-providers-cncf-kubernetes'
Available versions

4.3.0, 4.2.0, 4.1.0, 4.0.2, 4.0.1, 4.0.0, 3.1.2, 3.1.1, 3.1.0, 3.0.2, 3.0.1, 3.0.0, 2.2.0, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.2.0, 1.1.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.cncf.kubernetes

apache-airflow-providers-common-sql

Common SQL Provider

To install, run:

pip install 'apache-airflow-providers-common-sql'
Available versions

1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.common.sql

apache-airflow-providers-databricks

Databricks

To install, run:

pip install 'apache-airflow-providers-databricks'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.7.0, 2.6.0, 2.5.0, 2.4.0, 2.3.0, 2.2.0, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.databricks

apache-airflow-providers-datadog

Datadog

To install, run:

pip install 'apache-airflow-providers-datadog'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.datadog

apache-airflow-providers-dbt-cloud

dbt Cloud

To install, run:

pip install 'apache-airflow-providers-dbt-cloud'
Available versions

2.1.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1.

Reference

PyPI Repository

Python API Reference

airflow.providers.dbt.cloud

apache-airflow-providers-dingding

Dingding

To install, run:

pip install 'apache-airflow-providers-dingding'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.dingding

apache-airflow-providers-discord

Discord

To install, run:

pip install 'apache-airflow-providers-discord'
Available versions

3.0.0, 2.1.4, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.discord

apache-airflow-providers-docker

Docker

To install, run:

pip install 'apache-airflow-providers-docker'
Available versions

3.1.0, 3.0.0, 2.7.0, 2.6.0, 2.5.2, 2.5.1, 2.5.0, 2.4.1, 2.4.0, 2.3.0, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.2.0, 1.1.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.docker

apache-airflow-providers-elasticsearch

Elasticsearch

To install, run:

pip install 'apache-airflow-providers-elasticsearch'
Available versions

4.2.0, 4.1.0, 4.0.0, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 2.2.0, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.elasticsearch

apache-airflow-providers-exasol

Exasol

To install, run:

pip install 'apache-airflow-providers-exasol'
Available versions

4.0.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.exasol

apache-airflow-providers-facebook

Facebook Ads

To install, run:

pip install 'apache-airflow-providers-facebook'
Available versions

3.0.1, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.facebook

apache-airflow-providers-ftp

File Transfer Protocol (FTP)

To install, run:

pip install 'apache-airflow-providers-ftp'
Available versions

3.1.0, 3.0.0, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.ftp

apache-airflow-providers-github

GitHub

To install, run:

pip install 'apache-airflow-providers-github'
Available versions

2.1.0, 2.0.0, 1.0.3, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.github

apache-airflow-providers-google

Google services including:

To install, run:

pip install 'apache-airflow-providers-google'
Available versions

8.3.0, 8.2.0, 8.1.0, 8.0.0, 7.0.0, 6.8.0, 6.7.0, 6.6.0, 6.5.0, 6.4.0, 6.3.0, 6.2.0, 6.1.0, 6.0.0, 5.1.0, 5.0.0, 4.0.0, 3.0.0, 2.2.0, 2.1.0, 2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.google

apache-airflow-providers-grpc

gRPC

To install, run:

pip install 'apache-airflow-providers-grpc'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.grpc

apache-airflow-providers-hashicorp

Hashicorp including Hashicorp Vault

To install, run:

pip install 'apache-airflow-providers-hashicorp'
Available versions

3.1.0, 3.0.1, 3.0.0, 2.2.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.hashicorp

apache-airflow-providers-http

Hypertext Transfer Protocol (HTTP)

To install, run:

pip install 'apache-airflow-providers-http'
Available versions

4.0.0, 3.0.0, 2.1.2, 2.1.1, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.http

apache-airflow-providers-imap

Internet Message Access Protocol (IMAP)

To install, run:

pip install 'apache-airflow-providers-imap'
Available versions

3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.imap

apache-airflow-providers-influxdb

InfluxDB

To install, run:

pip install 'apache-airflow-providers-influxdb'
Available versions

2.0.0, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.influxdb

apache-airflow-providers-jdbc

Java Database Connectivity (JDBC)

To install, run:

pip install 'apache-airflow-providers-jdbc'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.jdbc

apache-airflow-providers-jenkins

Jenkins

To install, run:

pip install 'apache-airflow-providers-jenkins'
Available versions

3.0.0, 2.1.0, 2.0.7, 2.0.6, 2.0.5, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.jenkins

apache-airflow-providers-jira

Atlassian Jira

To install, run:

pip install 'apache-airflow-providers-jira'
Available versions

3.0.1, 3.0.0, 2.0.5, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.jira

apache-airflow-providers-microsoft-azure

Microsoft Azure

To install, run:

pip install 'apache-airflow-providers-microsoft-azure'
Available versions

4.2.0, 4.1.0, 4.0.0, 3.9.0, 3.8.0, 3.7.2, 3.7.1, 3.7.0, 3.6.0, 3.5.0, 3.4.0, 3.3.0, 3.2.0, 3.1.1, 3.1.0, 3.0.0, 2.0.0, 1.3.0, 1.2.0, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.microsoft.azure

apache-airflow-providers-microsoft-mssql

Microsoft SQL Server (MSSQL)

To install, run:

pip install 'apache-airflow-providers-microsoft-mssql'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.microsoft.mssql

apache-airflow-providers-microsoft-psrp

This package provides remote execution capabilities via the PowerShell Remoting Protocol (PSRP).

To install, run:

pip install 'apache-airflow-providers-microsoft-psrp'
Available versions

2.0.0, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.microsoft.psrp

apache-airflow-providers-microsoft-winrm

Windows Remote Management (WinRM)

To install, run:

pip install 'apache-airflow-providers-microsoft-winrm'
Available versions

3.0.0, 2.0.5, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.2.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.microsoft.winrm

apache-airflow-providers-mongo

MongoDB

To install, run:

pip install 'apache-airflow-providers-mongo'
Available versions

3.0.0, 2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.mongo

apache-airflow-providers-mysql

MySQL

To install, run:

pip install 'apache-airflow-providers-mysql'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.1.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.mysql

apache-airflow-providers-neo4j

Neo4j

To install, run:

pip install 'apache-airflow-providers-neo4j'
Available versions

3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.neo4j

apache-airflow-providers-odbc

ODBC

To install, run:

pip install 'apache-airflow-providers-odbc'
Available versions

3.1.1, 3.1.0, 3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.odbc

apache-airflow-providers-openfaas

OpenFaaS

To install, run:

pip install 'apache-airflow-providers-openfaas'
Available versions

3.0.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.openfaas

apache-airflow-providers-opsgenie

Opsgenie

To install, run:

pip install 'apache-airflow-providers-opsgenie'
Available versions

4.0.0, 3.1.0, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.opsgenie

apache-airflow-providers-oracle

Oracle

To install, run:

pip install 'apache-airflow-providers-oracle'
Available versions

3.3.0, 3.2.0, 3.1.0, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.oracle

apache-airflow-providers-pagerduty

Pagerduty

To install, run:

pip install 'apache-airflow-providers-pagerduty'
Available versions

3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.pagerduty

apache-airflow-providers-papermill

Papermill

To install, run:

pip install 'apache-airflow-providers-papermill'
Available versions

3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.papermill

apache-airflow-providers-plexus

Plexus

To install, run:

pip install 'apache-airflow-providers-plexus'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.plexus

apache-airflow-providers-postgres

PostgreSQL

To install, run:

pip install 'apache-airflow-providers-postgres'
Available versions

5.2.0, 5.1.0, 5.0.0, 4.1.0, 4.0.1, 4.0.0, 3.0.0, 2.4.0, 2.3.0, 2.2.0, 2.1.0, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.postgres

apache-airflow-providers-presto

Presto

To install, run:

pip install 'apache-airflow-providers-presto'
Available versions

4.0.0, 3.1.0, 3.0.0, 2.2.1, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.presto

apache-airflow-providers-qubole

Qubole

To install, run:

pip install 'apache-airflow-providers-qubole'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.qubole

apache-airflow-providers-redis

Redis

To install, run:

pip install 'apache-airflow-providers-redis'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.redis

apache-airflow-providers-salesforce

Salesforce

To install, run:

pip install 'apache-airflow-providers-salesforce'
Available versions

5.1.0, 5.0.0, 4.0.0, 3.4.4, 3.4.3, 3.4.2, 3.4.1, 3.4.0, 3.3.0, 3.2.0, 3.1.0, 3.0.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.salesforce

apache-airflow-providers-samba

Samba

To install, run:

pip install 'apache-airflow-providers-samba'
Available versions

4.0.0, 3.0.4, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.samba

apache-airflow-providers-segment

Segment

To install, run:

pip install 'apache-airflow-providers-segment'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.segment

apache-airflow-providers-sendgrid

Sendgrid

To install, run:

pip install 'apache-airflow-providers-sendgrid'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.sendgrid

apache-airflow-providers-sftp

SSH File Transfer Protocol (SFTP)

To install, run:

pip install 'apache-airflow-providers-sftp'
Available versions

4.0.0, 3.0.0, 2.6.0, 2.5.2, 2.5.1, 2.5.0, 2.4.1, 2.4.0, 2.3.0, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.2.0, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.sftp

apache-airflow-providers-singularity

Singularity

To install, run:

pip install 'apache-airflow-providers-singularity'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.1.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.singularity

apache-airflow-providers-slack

Slack

To install, run:

pip install 'apache-airflow-providers-slack'
Available versions

5.1.0, 5.0.0, 4.2.3, 4.2.2, 4.2.1, 4.2.0, 4.1.0, 4.0.1, 4.0.0, 3.0.0, 2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.slack

apache-airflow-providers-snowflake

Snowflake

To install, run:

pip install 'apache-airflow-providers-snowflake'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.7.0, 2.6.0, 2.5.2, 2.5.1, 2.5.0, 2.4.0, 2.3.1, 2.3.0, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.3.0, 1.2.0, 1.1.1, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.snowflake

apache-airflow-providers-sqlite

SQLite

To install, run:

pip install 'apache-airflow-providers-sqlite'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.sqlite

apache-airflow-providers-ssh

Secure Shell (SSH)

To install, run:

pip install 'apache-airflow-providers-ssh'
Available versions

3.1.0, 3.0.0, 2.4.4, 2.4.3, 2.4.2, 2.4.1, 2.4.0, 2.3.0, 2.2.0, 2.1.1, 2.1.0, 2.0.0, 1.3.0, 1.2.0, 1.1.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.ssh

apache-airflow-providers-tableau

Tableau

To install, run:

pip install 'apache-airflow-providers-tableau'
Available versions

3.0.1, 3.0.0, 2.1.8, 2.1.7, 2.1.6, 2.1.5, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.tableau

apache-airflow-providers-tabular

Tabular

To install, run:

pip install 'apache-airflow-providers-tabular'
Available versions

1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.tabular

apache-airflow-providers-telegram

Telegram

To install, run:

pip install 'apache-airflow-providers-telegram'
Available versions

3.0.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.0.2, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.telegram

apache-airflow-providers-trino

Trino

To install, run:

pip install 'apache-airflow-providers-trino'
Available versions

4.0.0, 3.1.0, 3.0.0, 2.3.0, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.trino

apache-airflow-providers-vertica

Vertica

To install, run:

pip install 'apache-airflow-providers-vertica'
Available versions

3.2.0, 3.1.0, 3.0.0, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.vertica

apache-airflow-providers-yandex

Yandex including Yandex.Cloud

To install, run:

pip install 'apache-airflow-providers-yandex'
Available versions

3.1.0, 3.0.0, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.0, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.yandex

apache-airflow-providers-zendesk

Zendesk

To install, run:

pip install 'apache-airflow-providers-zendesk'
Available versions

4.0.0, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 2.0.1, 2.0.0, 1.0.1, 1.0.0.

Reference

PyPI Repository

Python API Reference

airflow.providers.zendesk

Was this entry helpful?