This is a provider package for
trino provider. All classes for this provider package
airflow.providers.trino python package.
You can install this package on top of an existing Airflow 2 installation (see
for the minimum Airflow version supported) via
pip install apache-airflow-providers-trino
Cross provider package dependencies¶
Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.
You can install such cross-provider dependencies when installing from PyPI. For example:
pip install apache-airflow-providers-trino[common.sql]
Downloading official packages¶
You can download officially released packages and verify their checksums and signatures from the Official Apache Download site
Add _serialize_cell method to TrinoHook and PrestoHook (#27724)
Bump common.sql provider to 1.3.1 (#27888)
This release of provider is only available for Airflow 2.3+ as explained in the Apache Airflow providers support policy.
Move min airflow version to 2.3.0 for all providers (#27196)
Bump Trino version to fix non-working DML queries (#27168)
Add SQLExecuteQueryOperator (#25717)
Add common-sql lower bound for common-sql (#25789)
Fix placeholders in 'TrinoHook', 'PrestoHook', 'SqliteHook' (#25939)
hql parameter has been removed in
methods of the
Deprecate hql parameters and synchronize DBApiHook method APIs (#25299)
Unify DbApiHook.run() method with the methods which override it (#23971)
Move all SQL classes to common-sql provider (#24836)
Add test_connection method to Trino hook (#24583)
Add 'on_kill()' to kill Trino query if the task is killed (#24559)
Add TrinoOperator (#24415)
This release of provider is only available for Airflow 2.2+ as explained in the Apache Airflow providers support policy https://github.com/apache/airflow/blob/main/README.md#support-for-providers
TrinoHook add authentication via JWT token and Impersonation (#23116)
Make presto and trino compatible with airflow 2.1 (#23061)
Auto-apply apply_default decorator (#15667)
Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+.
If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade
Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded
automatically and you will have to manually run
airflow upgrade db to complete the migration.
Initial version of the provider.