apache-airflow-providers-common-io

apache-airflow-providers-common-io package

Common IO Provider

Release: 1.3.0

Provider package

This package is for the common.io provider. All classes for this package are included in the airflow.providers.common.io python package.

Installation

You can install this package on top of an existing Airflow 2 installation via pip install apache-airflow-providers-common-io. For the minimum Airflow version supported, see Requirements below.

Requirements

The minimum Apache Airflow version supported by this provider package is 2.8.0.

PIP package

Version required

apache-airflow

>=2.8.0

Cross provider package dependencies

Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.

You can install such cross-provider dependencies when installing from PyPI. For example:

pip install apache-airflow-providers-common-io[openlineage]

Dependent package

Extra

apache-airflow-providers-openlineage

openlineage

Downloading official packages

You can download officially released packages and verify their checksums and signatures from the Official Apache Download site

Was this entry helpful?